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Application I -  Real-time Protocol Analysis 

Section 1.0 Overview 

1.1 Introduction 

The Global System for Mobile communications is a digital cellular communications system. GSM 

standards are used to provide the interface between the various entities in GSM network.  

GSM networks presently operate in three different frequency ranges, 

 GSM 900 (operates in the 900 MHz frequency range; is used in most parts of the world - Europe, 

most of Asia, Australia, Africa, Middle East). 

 GSM 1800 or DCS 1800 (operates in the 1800 MHz frequency range; is found in a number of 
countries including France, Germany, Switzerland, the UK, and Russia). 

 PCS 1900 or DCS 1900 (used in the United States and Canada). 

The differences between these appear to be minor and mainly confined to power levels, frequency, and 
minor changes in signaling.  

GL‟s GSM Analyzer is used to analyze GSM protocols, a switching and signaling telecommunication 
protocol between MSC & BSC, BSC & BTS, MSC & SMLC, UMA & MS, and so on. Also supports 
proprietary 'Mobis' Interface (Motorola equivalent of the GSM A-bis interface) with additional license 
(XX151). This includes messages between BSC (Base Site Controller) - BTS (Base Transceiver Station) 
and BSC (Base Site Controller) - PCU (Packet Controller Unit) 

HDLC frames are parsed according to Q.921, SS7 information parsing is based on ANSI and ITU 
standards: T1.111, T1.112, T1.113, Q.703, Q.704, Q.708, Q.723, Q.763 & GSM information parsing is 
based on 3GPP TS 08.08¸ 3GPP TS 24.008, 03.40, 3GPP TS 04.11, 3GPP TS 08.58, 3GPP TS 04.18. 
MTP2 is parsed according to ANSI-ITU standards and the higher GSM layer information parsing 

depends on the user's selection of GSM 900, DCS 1800 & PCS 1900 according GSM variants. 

GL Communications supports the following types of GSM analyzers: 

 Real-time GSM Analyzer (Pre-requisites: GL's field proven E1 or T1 internal cards or Laptop E1 or 

T1 external units, required licenses Windows XP (or higher) Operating System)  

 Offline GSM Analyzers (Pre-requisites: Hardware Dongles and Windows XP (or higher) 

Operating System)  

 

1.2 Main Features 

 Interfaces supported are  

 A (Interface b/w BSC and MSC) 

 A-bis (Interface b/w BSC and BTS) 

 Mobis (Motorola Proprietary Interface b/w BSC and BTS and also b/w BSC and PCU) 

 Gs (Interface between SGSN and MSC) 

 Ls / Lb / Lp Interface (Interface between MSC and SMLC) 

 Up (Interface between UNC (UMA network controller) and MS) 

 Displays Summary, Detail, Hex-Dump, Statistics, and Call Detail Views. 

 Summary View displays MTP2, MTP3 information, GSM Message types, information about various 
channels used during the call, frequency hopping, and etc in a tabular format. 

 Detail View displays decodes of a user-selected frame from the summary view.  

 Decoding of many RR layer non-transparent messages such as „System Information‟, 
„Measurement Result‟, „Immediate Assignment‟ etc. 

 Statistics View displays statistics based on frame count, byte count, frames/sec, bytes/sec etc for 
the entire captured data. 

 Call Detail View displays call statistics such as number of active/completed calls, durations of the 

completed calls, Type of Call (e.g. SMS/Location Update/Authentication/Speech Call), IMSI/TMSI 
associated with each call. 

 Call Detail Recording feature includes data link groups that help in defining the direction of the 

calls in a given network and form logical groups comprised of unidirectional (either „Forward‟ or 
„Backward‟) data links. 
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 Hex dump View displays raw HDLC frame data as a hexadecimal and ASCII octet dump  

 Search and filtering capabilities. 

 Exports Summary View information to a comma delimited file for subsequent import into a 

database or spreadsheet. 

 Capability to export detail decodes information to an ASCII file. 

 Remote monitoring capability using GL's Network Surveillance System. 

 

Additional features supported by real time GSM analyzer are: 

 Streams can be captured on the selected time slots (contiguous or non-contiguous), sub-channels 
or full bandwidth.  

 Real-time filtering based on the frame length. 

 Supports decoding of frames with FCS of 16 bits and 32 bits, or none. 

 Recorded trace files can be played back using HDLC playback application.  

 Frames can be transmitted/captured in either, n x 64 kbps, or n x 56 kbps data channels. 

 Multiple streams of GSM traffic on various T1/E1 channels can be simultaneously decoded with 

different GUI instances. 

 The variations accommodated in the software are inverted or non-inverted data, and byte reversal 

or non-reversal. 

 

Additional features supported by Offline GSM Analyzer: 

 Trace files for analysis can be loaded through simple command-line arguments. 

 Multiple trace files can be loaded simultaneously with different GUI instances for offline analysis. 

 

1.3 Offline Protocol Analyzer 

GL‟s offline protocol analyzers are available as optional software. Functionally, they are similar to real-
time protocol analyzers that are integrated with T1E1 Analyzers.  

However, with Offline Protocol Analyzers, user can only decode the pre-captured files from any remote-

site. 

 

1.4 Supported Protocols 

A Interface (variants GSM 900, DCS 1800, PCS 1900) 

 MTP2 - Q.704, ITU-T Blue Book / ANSI T1.111-1996  

 MTP3 - Q.703, ITU-T Blue Book / ANSI T1.111-1996  

 SCCP - Q.713, CCITT (ITU-T) Blue Book / ANSI T1.112-1996  

 BSSMAP - 3GPP TS 48.008 10.0.0 

 MM & CC - 3GPP TS 24.008 V5.2.0  

 SMS - 3GPP TS 03.40 V7.5.0 & 3GPP TS 04.11 V7.1.0  

 Group Call Control - 3GPP TS 44.068 V9.0.0 is implemented to support VGCS (Voice Group Call 

Service) feature for GSM-R (Global System for Mobile Communications - Railway) 

 Broadcast Call Control - 3GPP TS 44.069 V9.0.0 is implemented to support VBS (Voice Broadcast 
Service) feature for GSM-R  (Global System for Mobile Communications - Railway) 
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Abis Interface (variants GSM 900, DCS 1800, PCS 1900) 

 LAPD - Q.921, CCITT (ITU-T) 

 BTSM - 3GPP TS 08.58 V8.6.0  

 RR - 3GPP TS 04.18 V8.13.0  

 MM & CC - 3GPP TS 24.008 V5.2.0  

 SMS - 3GPP TS 03.40 V7.5.0 & 3GPP TS 04.11 V7.1.0  

 Group Call Control - 3GPP TS 44.068 V9.0.0 is implemented to support VGCS (Voice Group Call 
Service) feature for GSM-R (Global System for Mobile Communications - Railway) 

 Broadcast Call Control - 3GPP TS 44.069 V9.0.0 is implemented to support VBS (Voice Broadcast 
Service) feature for GSM-R  (Global System for Mobile Communications - Railway) 

Gs Interface (variants GSM 900, DCS 1800, PCS 1900) 

 MTP3 - Q.703, ITU-T Blue Book / ANSI T1.111-1996 

 MTP2 (Layer 2) - Q.704, ITU-T Blue Book / ANSI T1.111-1996 

 SCCP - Q.713, CCITT (ITU-T) Blue Book / ANSI T1.112-1996  

 BSSAP+ - 3GPP TS 29.018 V6.0.0 (2004-06) 

Lb, Ls, Lp-Interfaces  

 RRLP - 3GPP TS 44.031 V 7.5.0  

 BSSLAP - 3GPP TS 29.018 V6.0.0 (2004-06) 

 SMLCPP -3GPP TS 48.031 V 6.6.0 

 LLP -3GPP TS 44.071 V 6.0 

 BSSAP-LE (BSSMAP-LE/DTAP-LE) 

 SCCP - Q.713, CCITT (ITU-T) Blue Book / ANSI T1.112-1996  

 MTP3 - Q.703, ITU-T Blue Book / ANSI T1.111-1996 

 MTP2 (Layer 2) - Q.704, ITU-T Blue Book / ANSI T1.111-1996 

UP interface 

 UMA Protocols (Stage 3) R1.0.4 (2005-05-02) 

 TS 24.008, Mobile radio interface layer 3 specification,  Core Network Protocols - Stage 3 

 TS 25.331, RRC Protocol Specification 

 TS 44.018, Mobile radio interface layer 3 specification 

 TS 48.018, Base Station System (BSS) - Serving GPRS Support Node (SGSN) 

 TS 48.008, BSS GPRS Protocol (BSSGP) 

 TS 45.008, Radio subsystem link control 

 TCP , UDP - RFC 793, RFC 768 

 IP - RFC 791 

 MAC 

Mobis Interface (requires additional license) 

 LAPD - Q.921, CCITT (ITU-T) 

 Mobis 

 RR - 3GPP TS 04.18 V8.13.0  

 MM & CC - 3GPP TS 24.008 V5.2.0  

 SMS - 3GPP TS 03.40 V7.5.0 & 3GPP TS 04.11 V7.1.0 

 Group Call Control - 3GPP TS 44.068 V9.0.0 is implemented to support VGCS (Voice Group Call 

Service) feature for GSM-R (Global System for Mobile Communications - Railway) 

 Broadcast Call Control - 3GPP TS 44.069 V9.0.0 is implemented to support VBS (Voice Broadcast 
Service) feature for GSM-R  (Global System for Mobile Communications - Railway) 
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Section 2.0 User Interface and Options 

2.1 Installation 

The real-time protocol analyzer is available as optional software with the GL‟s T1/E1 analyzer. Users 
require a GL‟s license to integrate the protocol analyzer with already existing T1/E1 Analyzer. Once the 
license has been installed properly using license installer, the application can be invoked as explained 
in the following section. 

For installing offline and remote protocol analyzers, first install T1 E1 hardware, server software, and 
HDLC capture software. At the remote site, install the GUI based Offline/Remote protocol analyzer 
application. For more details on installation of offline/remote protocol analyzer, refer to section 
Appendix A: Filter and Search Criteria. For details on installing T1E1 Analyzer, refer to T1E1 
Installation User Manual for the required Windows® operating system. 

2.2 Invoking Real-time Protocol Analyzer 

Double-click the T1/E1 Analyzer icon located on the desktop to invoke the application. The T1/E1 
Analyzer executable is located in the directory „\Program Files\GL Communications Inc‟. From the main 
window of T1/E1 Analyzer, click Special Applications > Protocol Analysis and select the required 

protocol analyzer as shown below: 

 

Figure 1: Invoking the Protocol Analysis 
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2.3 User Interface 

The user interface comprises of main menu, toolbar, sub menu toolbar and different views, which 
includes Summary View at the top, followed by the Detail, Hex Dump, Statistics, and optional Call 

Detail View at the bottom as shown in the figure below: 

 

Figure 2: Summary, Detail, Hex dump, Statistics Views 

The main menu tool bar comprises of File, View, Capture, Statistics, Database, Call Detail Records, 
Configure, and Help menu.The main menu and the tool bar are used to select an operation to perform. 
The status fields at the bottom of the window display miscellaneous status information. Most of the 

operations can be performed either using the main menu or the corresponding tool button. 

The features under these menus are explained in detail later, in this document. 

The protocol analyzer opens with Summary, Detail and Hex Dump as default panes. Statistics and Call 
Detail are optional panes, which can be viewed if required. User have the options to set the required 
panes by using Views > Define Views. The splitter separating the summary, detail and hex dump 
views can be adjusted according to user preferences. The summary view columns can be resized and 

reordered.  
 

 Summary View displays various columns such as Dev#, Frame Number, Time, Length, Error, 
Src/dest IP addresses, Frame Type, and so on. 

 User selects a frame in the Summary View to get the detail protocol field information in the Detail 

View.  

 Raw data for the selected Summary View frame is displayed in the Hex-dump View in HEX and 

ASCII formats. 

 



File Menu Features  

GL Communications Inc. 7 May 2011 

Document Number: XX150,OLV150-6.07-03 

Section 3.0 File Menu Features 

The File menu includes following submenus -  

 Start Real-time 

 Stop 

 Off-line 

 Close 

 Save As 

 Save As and Close 

 Export Details 

 Export Summary 

 

Figure 3: File Menu Options 

3.1 Start Real-time 

Users can capture and analyze frames in real-time and record all or filtered traffic into a trace file. The 

recorded trace file can then be analyzed offline and exported to ASCII file, or printed. 

 Note: 
This feature is applicable to real time analyzer only. 

 

To start the real-time analysis: 

 Click File >Start Real-time  

 Click Start Real-time  from the toolbar  

After you click the Start Real-time button, a warning message for overwriting the temporary trace file 
is displayed. If you want to overwrite click Yes, else, click No and save it as a new file in the desired 

location. This new file replaces the default specified in the capturing options dialog. 

 

Figure 4: Saving the trace file 

The real-time analysis is used to capture data on one or multiple T1/E1 lines on the specified timeslots 
simultaneously during transmission. The captured data is always stored in a temporary file. Before 
capturing is started, the capturing options and timeslots must be set. These settings are saved in the 
Windows® registry and can be reused between analyzer sessions.  

The Real-time analysis procedure entails the following steps to be performed: 
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1) Specify the file on which the transmission should be captured using the capture file options (refer 

to section Setting Capturing Options for further details). 

2) Specify timeslots and other Stream/Interface selections using Capture > Stream Interface 

Selection (refer to section Stream / Interface (Port)  Selection for further details). 

3) Specify the way in which the transmission should be captured to additional trace files using the 

Periodic Trace Saving option (refer to section Periodic Trace Saving Options). 

4) Start/Suspend the Real-time analysis using the Start/Pause menu options available under the file 

menu (Refer to sections Start Real-time and Stop/Pause for further details). 

5) Export captured information from Summary and Detail Views to files as explained in sections 

Export Details and Export Summary. 

6) Save current trace with a new file name (Refer to Save As and Close for further details). 

The following image shows the real time analysis: 

 

Figure 5: Real-time Analysis 

 

3.2 Stop/Pause 

 Note: 
This feature is applicable to real time analyzer only. 

 

To suspend real-time capturing, follow the steps given below. 

 Click File > Stop/Pause or 

 Click Stop  from the toolbar 
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3.3 Opening Trace for Offline Analysis 

Off-line analysis is equivalent to transmitting/capturing a file in pre-defined channels and decode 
standards. During off-line analysis the users can analyze the pre-captured *.hdl files. To open the trace 
for Offline Analysis, follow the steps given below: 

 Click File > Off-line as shown in the figure below Or 

 Click Off line from a File  from the tool bar 

 

Figure 6: Open a Trace from a File for Off-line Analysis 

 

Figure 7: Offline Analysis 
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Additionally, the files can be loaded using the command as shown in the figure below:  

 

Figure 8: Open a Trace File from Command Prompt  

 
 

3.4 Close Trace 

To close the trace file, follow the steps given below: 

 Select File > Close or 

 Click Close trace  from the toolbar. 

 

3.5 Save As and Close  

To save the trace file using a different name, follow the steps given below: 

 Select File > Save As and Close menu item Or 

 Click Save Trace to a Different File Name and Close  from the tool bar 

  

Figure 9: Save Trace As File Name and Close 

This feature is usually used to make sure that trace is saved in a different file than temporary trace file 
and will not be overwritten by accident. 
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3.6 Save As 

To save specific Frames/Packets in a new file or to append to an existing file, follow the steps given 
below: 

 Click File > Save As Or 

 Click Save As  from the tool bar. 

 

Figure 10: Save As 

 Select All to save all the captured frames 

 Select From to save all the frames whose frame length ranges within the specified values in „min‟ 
to „max‟ text boxes as shown in the above figure 

 Select Overwrite to overwrite the existing *.HDL files in the directory with the new captured 
frames 

 Select Append to append the frames/packets to the already existing *.HDL files in the directory. 

Trace file remains open after the “Save As” operation is completed. Close the trace file and  verify if 

the file has been successfully saved by opening the saved *.HDL file in offline mode.  
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3.7 Export Details 

To export the detail information of frames to an ASCII file, follow the steps given below: 

 Click File > Export Details Or. 

 Click Export Details  from the tool bar 

 

Figure 11: Exporting Trace to an ASCII File 

 

3.8 Export Summary 

To export the summary information to comma separated values (CSV) format, follow the steps given 
below: 

 Click File > Export Summary Or 

 Click Export Summary to a comma delimited file  from the tool bar 

Select the Columns to Export and save the export summary as text file. Select Export Headers to 

export a header line with column names preceding the summary data rows. 

 

Figure 12: Exporting Summary to an ASCII File 
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Section 4.0 View Menu Features 

The view menu includes -  

 Define Views to Display- Summary View; Right-click options in Summary View; Detail View; Hex 
Dump View; Statistics View; 

 Protocol Standard 

 User/Network Side Specification 

 Time Format 

 Latest Frame 

 Set filtering criteria  

 Activate or Deactivate filter 

 Search criteria 

 Next, Prev 

 Displays trace file name 

 Default Summary Columns 

 

 

Figure 13: View Menu Options 
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4.1 Define Views to Display 

Select View > Define Views to select Summary, Detail, Statistics and/or Hex-dump view as shown in 
the figure below, and click „OK‟ to view the details. 

 

 Note: 
Summary View should be selected to view the Detail and /or Hex Dump Views. 

 

 

Figure 14:: Define Views to Display 
 

4.2 Summary View  

The default Summary View displays the following information in the tabular format left to right: 

 Card number (one relative) - This field displays the device number on which the data is being 
captured. 

 Time slots-This field displays range of selected timeslots  

 Frame number - This represents the unique number assigned to each frame in the order it was 
captured. 

 Time: This field displays the time as configured by the user in View>Time Format. For more 
information refer to Time Displays. 

 Frame Length - This field displays the length of each captured frame. 

 Error: This field displays various error messages during capturing /decoding such as Frame error, 
Decode error, FCS error, and so on. 

Additional columns displayed corresponding to the other protocols is listed below: 

 

A Interface, Gs Interface -GSM 900/DCS1800/PCS1900 

 BSN/FSN (Backward Sequence Number/Forward Sequence Number): BSN and FSN, each 
of length 7-bit, are used to acknowledge the message signal units from the remote end of the 

signaling link. 

 BIB/FIB (Backward Indicator Bit/Forward Indicator Bit) - BIB and FIB, each of length 8-
bit, are used in the basic error control and acknowledgement functions. 

 Status Field: Status field in LSSU frames is an 8/16 bit field that indicates initiation of link 

alignment, quality of received traffic, and status of processors at either end of the link. 

 SLC (Signaling Link Code) - SLC Link code is a 4-bit code that identifies the link set carrying 
SS7 signaling information. The range of SLC is 0-15.For example; enter SLC value 23, as shown in 
the figure below to filter the frames that have the value as 23. 

 DPC (Destination point code): DPC represents a numeric address that uniquely identifies the 
receiving signalling point 

 OPC (Originating point code): OPC represents a numeric address that uniquely identifies the 

sending signalling point. This column shows the originating point code value. 

 SSN (Subsystem Numbers): SSN is used to allow messages to be addressed to specific 
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applications (called subsystems) at each signaling points 

 SCCP Message type: SCCP uses subsystem numbers (SSN) to allow messages to be 

addressed to specific applications (called subsystems) at each signaling points. 

 BSSMAP-Message: The BSS Management Application Part (BSSMAP) supports all of the 
procedures between the MSC and the BSS that require interpretation and processing of 
information related to single calls, and resource management. 

 MM (Mobility Mgmt) Message: This field displays mobility mgmt messages required to handle 
the procedures such as handover, Location Update etc of Mobile station with respect to circuit 
switched core network. 

 TMSI (Temporary Mobile Subscriber Identity): This field displays the value used to identify 

the mobile subscriber across the radio interface. TMSI is the real identity of the MS and is not 
usually transmitted over radio interface. 

 CC (Call Control)-Message: This field displays call control messages that are used to actually 

setup the call between MS and circuit switched core network. 

 Called Party/Called Subaddress: This field displays called party/called subaddress number that 
identifies the called party and is present in CC messages. 

 Calling Party/Connected/Redirecting #: This field displays calling party number that identifies 

the calling party and is present in CC messages. 

 SMS-CP: This field displays control plane messages of SMS protocol that are used before SMS 

data is transmitted. 

 SMS-RP: This field displays relay plane messages of SMS protocol that are exchanged before SMS 
data transfer and carries TP messages over it. 

 SMS-TP: This field displays transport plane messages of SMS protocol are responsible for actual 

transfer of SMS data over the network. These messages contain the actual user data (SMS data) 
in encoded (7 bit / 8 bit) format. 

 BCC (Broadcast Call Control) Message Type: This field displays the BCC message type such as 

CONNECT, SETUP, STATUS, TERMINATION, etc. 

 BCC Protocol Discriminator: This field displays the BCC protocol discriminator values such as 
broadcast call control, group call control, sms messages, mobility management messages, and 
etc. 

 GCC (Group Call Control) Message Type: This field displays the GCC message type such as 

SETUP, CONNECT, GET STATUS, and etc. 

 GCC Protocol Discriminator: This field displays the GCC protocol discriminator values. 

 Reg Test Message: This field displays the test messages sent across the link to test the integrity 
of the link. 

 Net Mgmt Message: This field displays the network starting that is used to manage from 

maintaining active link/ standby link, decide when the link should be down/up etc. 

 NMPC: This field displays the Destination Point Code in network management messages. 

 

Abis Interface  -GSM 900/DCS1800/PCS1900 

 Command/Response (C/R): The C/R bit indicates whether the frame contains a command or a 
response corresponding to the user/network. 

 Service Access Point Identifier (SAPI): This is a 6-bit field number that identifies the point 
where Layer 2 provides a service to Layer 3 in OSI. 

 Terminal Endpoint Identifier (TEI): This is a 7-bit field number that indicates the presence of a 
single terminal or multiple terminals. 

 Control Information (CTL): It displays different control information (user information, 

supervisory, and unnumbered). 

 Poll/Final Bit (P/F): A „1‟ in this bit indicates a poll when frame is a command, and when the 
frame is a response, a „1‟ in this bit indicates that the current frame is the last frame in the 
response. 

 Send Sequence Number (N (S)): N (S) is a 7-bit field that indicates the current information-
frames (I-frames). 

 Receive Sequence Number (N (R)): N (R) is a 7-bit field that indicates the number of the next 

information-frame expected by the node at the remote end. 
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 Function: It displays different LPAD functions. 

 BTSM Message (Base Transceiver Station Management): This column displays layer 3 

messages that are required to exchange Radio Resource mgmt messages to activate, maintain 
and release radio channel across Abis interfaces. It is also used to carry other DTAP messages 

such as MM /CC / SMS across the interface. 

 Channel Type: This field displays the type of channel being used for signaling SDCCH / BCH / 

SCH etc. 

 Time Slot (Air): This field displays logical channel of a TDMA frame that represents one Time slot 
and each TDMA frame comprises of total eight time slots. 

 Sub Channel (Air): This field displays logical channel that is further divided, and each fraction is 

known as sub channel. 

 RR Message: This field displays Radio Resource mgmt messages required to activate, maintain 
and release radio channel across Abis interfaces. 

 Hopping Channel: This field displays information about the type of RF channel like single RF 
channel and RF Hopping channel. 

 Absolute Rf Channel #: This field displays an identifier for the channel. 

 Hopping Sequence #: This column displays the traffic channels with the HSN hop over the same 
frequencies in the same order, but is separated in time by a mobile allocation index offset (MAIO). 

 

Gs Interface 

 BSSAP+(Base Station System Application Part Plus) Message: This field displays BSS 
Application Part plus that is used to support signaling between the VLR (Visitor Location Register) 
and SGSN (Serving GPRS Support Node) on the Gs interface. 

 SLS: This field displays the 8-bit SLS value that is normally used for load sharing across signaling 

links. 

 

Lb, Ls, Lp-Interfaces 

 BSSAP -LE Message Type – BSSAP-LE is an extension to BSSAP (Base Station System 
Application Part) that contains messages and parameters specific in the support of LCS 

(Location Services). The following subsets of BSSAP-LE are defined as BSSMAP-LE (Base 
Station System Mobile Application Part - LCS Extension) and DTAP-LE (Direct Transfer 

Application Part - LCS Extension). 

 BSSLAP Message Type – The BSS LCS Assistance Protocol (BSSLAP) and the BSSAP LCS 
Extension (BSSAP-LE) support LCS functions (e.g., positioning measurements, assistant 
measurements) and is independent of lower protocol layers. The BSSLAP layer may be absent if its 

functions are supported in the BSSAP-LE layer 

Mobis Interface 

 Compact Interface Type – Displays Mobis Protocol Interface type in Compact header format 

 Compact Message Type - Displays Mobis Interface type in Compact header format 

 Executive Interface Type – Displays Mobis Protocol Interface type in Executive header format 

 Executive Message Type - Displays Mobis Interface type in Executive header format 

 

Up Interface (UMA) 

 Destination & Source IP Address – Displays the Destination & Source IP Address of the messages 

 TCP, UDP Destination & Source Port – Displays the TCP/UDP Port Address of the messages 

 Protocols – Identifies the UMA control protocols 
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4.2.1 Setting a Relative Time 

Select a particular frame in Summary View and right-click to select Set Relative Time. 

The relative capture time stamp of all other frames will be calculated relative to the selected frame as 

shown in the figure below. The selected frame becomes a baseline and the relative time above the 
selected frame shows that frames are captured before this frame. Also the relative time below this 
baseline shows that the frames are captured after this frame. 

 

Figure 15: Set Relative Time 
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4.2.2 Summary Column Selection 

Select a particular frame in summary view and right-click to select Summary Column Selection or 

click on the  button from Configure > Protocol and GUI Options to 

open the Analyzer GUI and Protocol Configuration window as shown in the figure below: 

 

Figure 16: Select Columns to Display 

This window is used to select the columns that are to be displayed in the Summary View. 

Select the desired columns to be displayed from DISPLAYED Summary columns pane to display the 
columns in the summary view. 

 Click All Columns to display all the columns in the Summary View. 

 Click Sel Only to display a particular column in the Summary View. 

 Click and drag columns up and down in the “DISPLAYED” summary column list to reorder them. 

 Click and drag the columns to the right side of the pane to delete them or use the keyboard 

“Delete” key. 

 Click Undo Delete or Restore to get the columns back to the left pane. 

 Click Display Selected Columns from the HIDDEN Summary columns pane to view the 

columns, which are hidden. 

In addition to column selection, this window allows users to reorder the columns appearance that is 

displayed in the Summary View, which is explained in the section below. 
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4.2.3 Column Resizing and Reordering 

The users can resize and/or reorder the columns in Summary View. From Select Summary Columns 
window (under Configure > Protocol and GUI Options), click and drag the columns to different 

positions as shown in the figure below. The figure shows the Time (Relative) and Len columns are 
reordered and TSlot and Frame # columns are resized. 

 

Figure 17: Column Resizing and Reordering 

In addition to reordering, the Summary columns can be resized. Click and drag the Summary column 
headers to resize them.  
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4.2.4 Repositioning Summary View  

Enter a new current frame number to position at the top of the summary view and click GoTo button 
as shown in the figure below: 

 

Figure 18: Repositioning the Summary View 

This operation may be executed even during the real-time capturing. If filter is active the frame 

number refers to displayed (filtered out) frames. 
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4.2.5 Summary Colors 

Select a frame in Summary View and right-click to select Summary Colors as shown in the figure 
below. Summary View is shown in different colors based on the selected columns. 

1) For example, select Len (Frame Length) option and click Ok. 

 

Figure 19: Set Summary Colors 

Observe that different colors are set based on the values in the Len column, in other words, the 
frames having the same length values will have a unique color set for it as shown in the figure above. 

4.2.6 Define Views 

For detail information on this refer to section Define Views to Display. 
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4.3 Detail View - Selecting Individual Frame 

Click to highlight a frame in Summary View to display the frame-specific details in the Detail View. 

 

Figure 20: Selecting Individual Frame 

The Detail View displays frame information in the following sequence: 

A-Interface 

 Frame Summary Information 

 MTP Layer information 

 SCCP Layer information 

 BSSMAP / DTAP (MM /CC / SMS)  

Abis Interface 

 Frame Summary Information 

 LAPDm Layer information 

 BTSM Layer 

 Layer 3 information (RR / MM / CC / SMS) 

Gs Interface 

 Frame Summary Information 

 MTP Layer information 

 SCCP Layer information 

 BSSAP Layer information 

Lb, Ls, Lp-Interfaces 

 MTP Layer information 

 SCCP Layer information 

 BSSAP Layer information 

 BSSLAP Layer information 

Up Interface – UMA 

 MAC Layer information 

 IP, TCP, and UDP Layer information 
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Mobis Interface 

 Frame Summary information 

 Mobis Layer 

Detail view of A interface is as shown in the figure below: 

 

Figure 21: Detail View 

4.4 Hex Dump View 

 

Hex Dump view displays raw frame data as a hexadecimal and an ASCII octet dump. 

4.5 Statistics View  

Various statistics can be calculated based on the protocol fields. For more information refer to the 

Statistics section. 



View Menu Features 

GL Communications Inc. 24 May 2011 

Document Number: XX150,OLV150-6.07-03 

 

4.6 Protocol Standard 

Use View > Protocol menu item to select the decoding standard for parsing and displaying 
information. The decoding standard does not affect information saved to a disk file and therefore can 

be changed at any time. 

GSM Analyzer supports A-Interface, Abis, Gs interfaces for different versions of GSM such as, GSM 
900, DCS 1800 and PCS 1900, Up Interface, Lb, Ls, Lp Interfaces, and Mobis Proprietary 
Interface.  

 

Figure 22: Select Protocol Standard 
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4.7 User/Network Side Specification 

Select As Captured option button to retain the selected user/network options at the time of capturing. 

Select Inverse Captured option to inverse the selected user/network options effective at the time of 
capturing. 

Select User Defined option button to specify the network side cards. This option can be specified 
when multiple cards are used. Enter the card number, which should be on the network side. 

The user/network side specification is set initially using the Capture Options > Stream/ Interface 
dialog as explained in the section User / Network Side Specification. 

 

Figure 23: User/Network Side Specifications  

 

4.8 Time Displays 

Four time formats are supported for both real-time and offline analysis. These time formats can be 
changed during both off-line and real-time operations by selecting the required time format either from 
View > Time Format menu item or by clicking on the time column header in the Summary View 

shown in the figure below. 

 Relative time 

 System time 

 Date and time 

 Difference time 

 

Figure 24: Time Displays 
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4.8.1 Relative Time 

In the Relative time format, the time of capture of each frame is displayed relative to the time of a 
selected frame. In this format, time value of the selected frame when the option is activated is always 

0:00:00:000000. 

If, for instance, second frame has the time value as 0:00:20:000000, it means that second frame was 
captured after 20 seconds since the first frame was captured. Thus the time value corresponding to 
each frame is obtained by the difference between the time of capture of that frame and time of capture 
of 0th frame. Preceding frames have negative relative time and following frames have positive relative 
time. 

 

4.8.2 System Time 

This option displays the system (local computer) time when frames were captured. For offline analysis, 
the system time option shows the time when the trace was captured earlier. 

For instance, during real-time capture, if the capture time displayed for the first frame is 
14:53:24:015411, it means that the first frame was captured at 2.53 P.M., 24 seconds, 015411 
microseconds local system time. 

 

4.8.3 Date and Time 

Date and Time format shows local date and system (PC) time during the real-time capturing of the 
frames. For off-line analysis, the system time option shows the date and time when the trace was 
captured earlier. The display is in the form of year, month, day, hours, minutes, seconds and 
microseconds. 

 

4.8.4 Difference Time 

The Time Difference format displays the time difference between consecutive frame capture times. For 
each frame it is this frame time minus the preceding frame time.  

 

4.9 Latest 

 

 Note: 
This feature is applicable to real-time analyzer only. 

 
 

The View > Latest option enables/disables automatic screen refresh and repositioning of the 
Summary and Detail View to the latest captured frame. This option does not have any effect in the off-
line analysis mode and is used only for real-time analysis to refresh screen approximately every two 
seconds. When the menu option is checked the automatic repositioning to the latest captured frame is 

enabled. 

 

Figure 25: Auto Screen Refresh During Real-time Analysis 
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4.10 View Filtering Criteria 

The View Filter is used real-time and offline to display and subsequently save, export and print a 
subset of frames satisfying a certain filtering criterion. The active filter is used as WYSIWYG (What You 
See Is What You Get). When filtering is active, the subsequent save as, export and or print will apply 
only to the filtered frames, otherwise, all the frames will be affected by the operation. 

All captured frames are preserved and will be displayed when filter is deactivated. The filtering criterion 
is effective either until the criterion is changed, de-activated or the analyzer is closed. After the filtering 
criterion has been specified, the frame filtering can be activated or de-activated at any time. 

 

4.10.1 Setting Filtering Criteria 

The filtering criteria are set for protocol fields and various parameters supported for the respective 
protocol standard. The parameters satisfying the conditions may be included or excluded from the 
result using the Include or Exclude options. All the selected criteria logically use OR or AND 
operations. A frame is filtered if at least one criterion matches (OR), or each criteria matches (AND). 

 

 Note: 
For more information on the parameters provided in the filtering criteria, refer to the section Appendix A - 
Filtering and Search Criteria. 

 Select View > Filtering Criteria menu item or  

 Click Filtering Criteria  form the toolbar. The filter selection dialog is displayed as shown in 
the figure below 

 Click on the  button from Configure > Protocol and GUI Options 

 

Figure 26: Setting Filtering Criteria 

Just setting the filtering criteria is not sufficient to start filtering. After the filtering criteria have been 
set, activate filter as explained below. 
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4.11 Activate Filter 

Activate filter activates the filtering criterion and displays only filtered frames. 

 Select View > Activate Filter menu item as shown in the figure below or 

 Click Activate Filter  from the toolbar 

 

Figure 27: Activating Filter 

If no filtering criterion is selected, both View > Activate Filter menu item and the corresponding 
button are disabled. Therefore, setting filtering criteria must precede the filter activation.  

The active filter affects subsequent save, export and print operations. It works as WYSIWYG (what you 

see is what you get). 
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4.12 Deactivating Filter  

Deactivating filter removes filtering and displays all the frames in the trace. 

 Select View > No Filtering menu item as shown in the figure below or 

 Click Deactivate Filter  from the toolbar 

 

Figure 28: Deactivating Filter 
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4.13 Searching for Specific Frames 

First, the search criterion has to be set and then „Next‟ or „Prev‟ function is invoked to search from 
the current record towards end of trace (next) or beginning of the trace (prev). If filtering is active the 

search operation is conducted among the already filtered frames. 

 

4.13.1 Setting Search Criteria 

 Select View > Search Criteria menu item or 

 Click Find  from the toolbar to open search criteria window as shown in the figure below 

 Click on the  button from Configure > Protocol and GUI Options 

 

Figure 29: Setting Search Criteria 
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4.14 Forward Search & Backward Search 

 

Figure 30: Searching Forward or Backward Options 

 

4.14.1 Searching Towards the End of the Trace (Forward Search) 

This operation will search from the current Frame in the summary view towards the end of the trace. 
To invoke this operation, follow the steps given below: 

 Select View > Next menu item as shown in the figure below or  

 Click  from the toolbar 

 

4.14.2 Searching Towards the Beginning of the Trace (Backward Search) 

This operation will search from the current frame in the summary view towards the beginning of the 
trace. To invoke this operation, follow the steps given below: 

 Select View > Prev menu item as shown in the figure below or  

 Click  from the toolbar 
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4.15 Display Trace File Name 

Select View > Display trace file Name menu item to view the filename under which the analyzer 
capture frames during real time or offline-trace as shown in the figure below. This option is useful 

when the file name is very long and is truncated in the status pane. 

 

Figure 31: Trace File Name 

 

4.16 Default Summary Columns 

To return to the Default Summary Columns from resized/reordered columns, click the View > 
Default Summary Columns option as shown in the figure below: 

 

Figure 32: Default Summary Columns
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Section 5.0 Capture Menu Features 

 

 Note: 
Capture Menu features are applicable to real time analyzer only. 

 

5.1 Periodic trace saving options 

Periodic trace saving is used to preserve all real-time captured data. Frames are saved to separate 
trace files by size or time criteria and capture is limited only by the available amount of hard disk 
space. 

Select, Capture > Periodic File Saving Specifications, to open the screen as shown in the figure 

below. 

 

Figure 33: Periodic File Saving Specifications 

Save Directory: 

Click  browse button to select the path of the directory where the files will be saved. 

Save File Names: 

Sequential File Names 

This file naming convention saves the trace files with user-defined prefixes along with the numbers 

indicating the sequence of the file. Select Sequential File Names radio button and enter a name in 
the file name prefix entry field. Use the slider control to indicate the total number of files to be saved. 
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You can drag the slider handle to any position using the mouse or simply click to the left or right of the 
slider handle to move it. You can control the slider by number of digits.  

Example: Enter the file name prefix as „ff‟ and set the slider control to third position of the ruler in the 
number of digits slider box. Now the files will be saved from ff000 up to ff999 in the user-defined 

directory. 

Date/Time Formatted Names: 

This file naming convention saves the trace file with date-time prefixes. Select Date/Time Formatted 
Names radio button to obtain the file name saved with the year, month, date, and hour. 

Example: 

Enter the file name prefix as %Y%M%D_%H%I in the Date/Time Formatted Names text box. Verify 
that the trace files are saved in „20050531_0953.HDL‟ format in the user-defined directory. The 
formatting specification refers to the year, month, day, hour and minute (date and time stamp). 

Create a New File After the Specified Limit has been Reached: 

Select either File Size Limit, Frame Count Limit, or Time Limit option and specify the limit in the 
Limit Value entry field. 

Restrict or Recycle After N Files Options: 

Select Keep N Latest files, Stop After N Files, or, Unrestricted option to get the desired number of 

trace files. 

Keep N Latest files – Restricts the file saving only for last „N‟ number of files, where „N‟ is the value 
set in the text box. When N is reached the older files will be overwritten by the most recent files 
keeping the total number of files equal to N. 

Stop After N Files - Restricts the file saving only for first „N‟ number of files, where „N‟ is the value set 
in the text box. After the limit has been reached, the periodic saving stops. 

Unrestricted - This option does not restrict the number of files being saved. This option limits the 

periodic saving to the available disk space only. 

For Example: 

Enter the value as 10(N=10) in the entry field and select Keep N Latest files radio button. Only ten 
files will be kept. They will contain the latest captured data. 

Enter the value as 10(N=10) in the entry field and select Stop After N Files radio button. Initial 10 

files are obtained and the process is stopped. 

 

 Note: 
Select Enable Periodic Saving and Start real-time tracing options (provided under Configure > Startup 
Options) before setting the Periodic File Saving Specifications. 
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5.2 Setting Capturing Options 

 

Figure 34: Capture File Options 

From the main menu select Capture > Capture File Options specify a temporary file name for 
capturing, the maximum size of this file in bytes and the capturing limit in frames or time period. 

The capture settings are saved in the Windows registry when the user exits the application. They need 
not be entered each time application is started. 

Specific settings can also be saved using Save menu option and subsequently loaded when needed. 

The file name can be either typed in the entry field or selected using the file dialog by clicking "…" 
button. The limit in bytes should be specified as a positive number, for example, 50000000 indicate 
that the maximum trace file size is 50Mb. If the limit is specified using the time format, for example, 

12:22:20, then capturing stops after 12 hours, 22 minutes and 20 seconds.  

Capturing stops when either the maximum trace file size in bytes is reached or the capturing limit is 
exceeded when circular capture buffer is not used. 

For infinite capturing, select the "Circular Capture Buffer" check box. When end of the capturing 
buffer is reached, the capturing does not stop. Instead, the oldest trace records are purged from the 
buffer and the new ones are placed at the end of the circular buffer. 

 

 Note: 
The maximum file size in bytes can be set from 64k (2^16) to 2G (2^31-1) Only. When capturing is completed 
the unused reserved bytes are released. Closed trace file will shrink to the minimum size sufficient to hold the 

captured information. 

 

Various options are available for saving trace file, refer to Periodic Trace Saving Options for details. 
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5.3 Stream / Interface (Port) Selection 

The Stream /Interface Selection dialog allows a user to specify ports for monitoring, and 

user/network side capture. To open the Stream /Interface Selection, follow the steps below: 

 Select the Capture > Stream/Interface Selection as shown in the figure or  

 Click Stream/Interface  from the toolbar 

 

Figure 35: Stream/Interface Selection 
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5.3.1 Port and Timeslots Selection 

The time-slot selection dialog allows user to specify devices and corresponding time slots on which the 

data is being captured. 

For T1, all (0-23) or required timeslots may be selected. 

While for E1 systems, excluding timeslots 0 and 16 (for CAS signaling only), all or the required 

timeslots may be selected. 

Selection of timeslots may be contiguous or non-contiguous (N*64 kbps Hyper-Channel, Single channel 
and Sub channels).  

Optionally, frames may also be captured based on their FCS (16 bits, 32 bits, none). 

Note: For N*56 kbps Hyper-Channel selection, the selection of timeslots should be contiguous. 

5.3.2 User/ Network Side Specification 

This option is used in protocol analysis for selection of uplink or downlink monitoring.  

Along with the port selections, users can specify if the card is monitoring the traffic from user-side or 

from network-side. If user is monitoring traffic originated from user-side (uplink), then cards should be 
unchecked and for capturing traffic originated from network-side (downlink), the cards should be 
checked as shown in the figure below.. The user/network side specification may also be set using the 
View>User/Network Side Specification dialog as explained in User/Network Side Specification. 

 

Figure 36: User/ Network Side Specification  

 
 

Note: The first check box is meant for card1, the second for card2, and so on. 
 

5.3.3 Bit Inversion 

Bit inversion changes each bit in received octets from 0 to 1 and 1 to 0. (See the figure below) 

Check the box as shown in the figure below to enable bit inversion. 

 

Figure 37: Specifying Bit Inversion Option 

5.3.4 Octet Bit Reversion 
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Octet bit reversion changes order of bits in each octet in such a way that the most significant bit 
becomes the least significant bit. For example, 0101001 is changed to 1001010. (See the figure below) 

 

Figure 38: Specifying Octet Bit Reversion Option 
 

Note: 
Both inversion and reversion must be used with care. In most cases bit inversion and reversion are not used in 
real-time systems. 

 

 

5.3.5 HDLC FCS 

 

Figure 39: Specifying FCS Value 

This allows users to decode frames with FCS 16 bits, FCS 32bits, or no FCS options. 

All as Port1: The settings of port 1 is applied to other ports 

All as Port 1, 2: In case of multiple ports the settings of port1 and 2 are replicated to all odd ports 
and even ports respectively. For ex: settings of port1 are replicated to port 3 and so on. 

5.3.6 Data Transmission Rate 

 

Figure 40: Specifying Channel Selections 

Selection of the data transmission rate in various modes like single channel, sub channels, or hyper-
channels is possible. 

Single Channel 

If all eight bits in a byte are used for data transmission, then this is referred to as 64 kbps format.  If 

only seven bits out of eight are used for data transmission, then this is referred to as 56 kbps format.  

Hyper Channel 

Multiple channels may be defined per card.  

Nx64 Kbps: This indicates selection of multiple timeslots (contiguous or non-contiguous) each of 64 
Kbps  

Nx56 Kbps (Bits 1-7): This indicates selection of multiple timeslots (contiguous) of each 56 Kbps 
with bits selected (1-7) 

Nx56 Kbps (Bits 2-8): This indicates selection of multiple timeslots (contiguous) of each 56 Kbps 
with bits selected (2-8) 

Sub channel 

In addition, the data may be transmitted on any of the user-defined bits (contiguous only), in which 

case, the user must select one of the options and its corresponding DS0 bits under Subchannels 8-56 
kbps pane. The actual sub channels comprising a lower bandwidth pipe are selected using the 
subchannel selection list box. 
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Depending on data transmission rate, the number of subchannels can be selected according to the 
table below. Each pipe 8 - 56 kbps can be comprised only from the contiguous subchannels. For 
example for 32 kbps pipe the following sub channel selections are valid 1-4,2-5, 3-6, 4-7. On the other 
hand, selecting subchannels 1, 2, 4 and 5 for 32 kbps is invalid: the total bandwidth is 32 kbps for 

these four selected subchannels, however they are not contiguous. 

 

Subchannel  

Rate 

Subchannels 
per Time Slot 

Example Example Explanation 

8 1,2,3,4,5,6,7,8 

 

Three Independent 

pipes are specified: 
1-2, 4 and 6. Each is 
8 kbps 

16 1,2,3,4 

 

Two pipes  

16 kbps each are 
specified. These two 
pipes are 1-2 & 3-4 

24 1,2 

 

Two pipes 24 kbps 

each are specified. 
First pipe 1-3 
subchannels, second 
6-8 subchannels  

32 1,2 

 

Two 32kbps pipes 
take entire DS0. First 
one 1-4 subchannels, 

second 5-8 

subchannels 
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40 1 

 

One pipe 40 kbps 

takes subchannels 1-
5.  

48 1 Similar to 40 kbps but 6 

consecutive subchannels must be 
selected 

 

56 1 Similar to 40 kbps but 7 
consecutive subchannels must be 
selected 
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5.4 Setting Capture Filter using Real-time Analyzer 

Select Capture > Capture Filter option to directly exclude LSSU (Link Status Signal Unit), FISU (Fill-
in Signal Unit) frames or any other user-defined frames. LSSU frames (of length 5) communicate 
information about the signaling link between the nodes on either end of the link. FISU frames (of 
length 7) support the monitoring of link traffic because they undergo error checking  

For example, enter the number of the frames, say 5 and 7, and click OK as shown in the figure below. 
Frames of length 5 and 7 will be excluded during real-time capture. 

Figure 41: Capture Filter 

 

5.5 GUI and Protocol Options 

Switches to GUI and protocol list: selecting columns, protocol standard, filtering criteria, search 
criteria, etc. For more information refer to Configure Menu Features. 
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Section 6.0 Statistics 

Protocol statistics is one of the main features of protocol analyzers. Statistics are calculated based 
on the protocol fields. The pane displaying statistics in protocol analyzer is as shown in the figure 
below: 

 

Figure 42: Protocol Analysis with Statistics View 
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6.1 Steps to Display Statistics 

Statistics can be calculated and displayed in off-line and real-time modes.  

In both cases statistics must be defined first using „Define/Edit‟ dialog as shown in the figure below 

and subsequently statistics view must be opened using the Statistics > Open Statistics View or 

using View > Define Views to Display.  

For real-time capturing, statistics view must be open before tracing is started. 

 

Figure 43: Statistics Definition Dialogue 

 

The statistics definition dialog has the following elements: 

 Field Names displayed as tree view in the upper left corner. This tree view is used to select a 
parameter for statistics calculation for the appropriate layer. 

 Use Type (UT) selection list box in the upper right corner allows users to select either Total, Key 

or Field type as statistics calculation type for each field name. 

 Statistics Type (ST) list box allows users to select additional parameters (Frame count, Current 

Frames, Max, Min etc) for each of the field name selected. Selecting a parameter under this frame 
is a must, if the user has selected any Field Name as Use Type. 

 Range List, Value Set or Wild Card can be specified in the entry field below the statistics type 
list box to further narrow down the selection for the required statistics calculation. 

 Add/Mod (Add/ Modify) button is used to apply all the values selected for each field for 
calculation. On the contrary, the Remove button is used to remove the selections made for each 
field name. 

 Once the Add/Mod button is clicked, the Selected Statistics Information pane at the bottom 

of the dialog lists the conditions set for each field and provides buttons to remove the selected or 
all settings. All fields defined as Total UT, Key UT or Field UT must appear in this pane to 
participate in statistics calculation as shown in the figure above. 
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6.1.1 Selecting Field Names (Step 1) 

In the protocol tree view, navigate to the protocol layer to which the field item belongs and click to 
select this item. The supported layers for the protocol analyzer and the field parameters for respective 

layer will be displayed as shown in the figure below: 

 

Figure 44: Selecting Field Names 
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Classifying Fields under Field Names 

All field names in the protocol displayed in the tree view belong to one of three types: 

 Numeric 

 String 

 Enumerated (set) 

Field names can be distinguished based on the icons representing them as shown in the figure below. 

 

Figure 45: Field Types 
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6.1.2 Defining Use Type (UT) and Statistics Type (Step 2) 

Use Type (UT) 

The UT can be total, key or field types. Selecting proper type defines the table displayed in the 

Statistics View. At least one total or key UT must be defined. Total and Key UT directs creation of 

statistics view columns for the selected fields and also rows with unique aggregate value of Total and 
Key columns. 

Total UT has dual role. Firstly it‟s used as a Key UT, defining rows with unique set of column values in 
the Statistics View. Secondly, it directs the statistics engine to display an additional row for totals 

(sum). The latter is similar to the sum function in the spreadsheets. 

Unique set of column values means that different rows have a unique combination of values in the 
Key/Total columns.  

Field UT defines only separate columns where the calculated Statistic Type is placed for the 
combination of key values. 

The UT can be set as Total, Key or Field. A minimum of one UT must be defined for each field 
selected under Field Names. 

Statistics Type (ST) 

The following statistic types are available: 

 Frame Count 

 Frame Percent 

 Byte Count 

 Byte Percent 

 Current Frames/Sec 

 Current Bytes/Sec 

 MAX Frames/Sec 

 MAX Bytes/Secs 

 MIN Frames/Sec 

 MIN Bytes/Sec 

 AVG Frames/Sec 

 AVG Bytes/Sec 

 MIN 

 MAX 

 SUM 

 AVG 

MIN, MAX, SUM and AVG should be specified only for numeric fields. As explained in the section 

Classifying Fields under Field Names, all the fields belong to one of the following categories: numeric, 
string and enumerated (sets). When the same ST is specified for multiple fields, a new column is 
created in the statistics view for each field name. 

Additional columns consume resources and slow down statistics calculation process. Only MIN, MAX, 
SUM and AVG columns will be different for different fields, other columns like Frame Count, Frame 
Percent, Byte Count and more will display the same information and will not be useful. 
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6.1.3 Update Selected Statistics Information List (Step 3) 

 

Figure 46: Selected Statistics Information List 

After selecting the required Use Type and statistics Type, click Add/Mod button to add the selected 
statistics in the information list.  

Click Apply shown on the figure above to activate the newly defined statistics information. If the 
Statistics Definition dialogue is closed without clicking on the Apply button will discard all the newly 
defined statistics. 
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6.1.3.1 Example 1 - Statistics with a Key UT 

Key UT: This option creates a unique column in the Statistic View, and a row for each unique value 
combination associated with all key and total columns. For example: 

1) Open the sample trace file in offline analysis mode. 

2) To define statistics, click Statistics > Define/Edit. 

3) Select the field „Device #‟ under physical layer, and select Key UT as the use-type., and Frame 

Count as statistics type  

4) Click Add/Mod button and then click Apply. The selected statistics pane appears as shown in the 
figure below. 

 

Figure 47: Define Statistics with a Key UT  
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5) Click Statistics > Open Statistics View to open the statistics frame which appears as shown in 
the figure below: 

 

Figure 48: Statistics with a Key UT 

In the above example, the data is captured using device # 1 and 2, and therefore the key values of 1 
and 2 are displayed under the Device# column. 
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6.1.3.2 Example 2 - Statistics with a Total and a Key 

Total UT: This option not only makes the column a key column but also creates an additional total row 
for each unique value of the column. 

Total UT and Key UT values combined together uniquely define a row in the Statistics View. 

Key UT - Key UT defines a unique column value that can be used for calculating a Statistic Type like 

frame count, sum, avg, min, max, etc. This calculated statistics will be displayed only if all the key UT 
values are unique and are numeric else the Statistics View displays just the word „Total‟ in the row 
dedicated for the same purpose. For example -  

1) Open the sample trace file in offline analysis mode. 

2) To define statistics, click Statistics > Define/Edit. 

3) Select the field „Device #‟ under physical layer, and choose Total UT as the use-type and then 

select Frame Count as statistics type. 

4) Click Add/Mod button and then click Apply. 

5) Select the field „Message Type‟ under BTSM layer, and then select Key UT as the use-type.  

6) Click Add/Mod button and then click Apply. The selected statistics pane appears as shown in the 

figure below. 

 

Figure 49: Select Statistics with a Total and a Key 
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7) Click Statistics > Open Statistics View to open the Statistics View as shown in the figure 

below: 

 

Figure 50: Statistics with a Total and a Key  

In the above example, unique rows are defined based on field (BTSM Message Types) selected as the 
Key UT, and columns (frame count for each device) are defined based on the statistics type selected 

for this Total UT. Since the device is selected as Total UT, additional row displaying the total frame 
count per device are displayed. 
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6.1.3.3 Example 3 - Statistics Total and Field UT 

Field UT: This option defines additional columns for the parameters selected under Statistics Type 

frame. Field UT creates just an additional column for the selected field. However, differently from Key 

UT and Total UT, the Field UT does not create additional rows for each unique value associated with the 
field. For example, 

1) Open the sample trace file offline. 

2) To define statistics, click Statistics > Define/Edit. 

3) Select the field „Device #‟ under physical layer, and choose Total UT as use-type. 

4) Select Timestamp under „Physical Layer‟, and choose Field UT as use-type. To get the frame 

count for each unique timestamp, select Frame Count as the Statistics Type. 
 

 Note: 
Notice that setting the Timestamp as a Field UT does not create unique rows for each unique timestamp value as in 
the previous example where the UT was set as the Key UT. 

 

5) Click Add/Mod button and then click Apply. 

 

Figure 51: Define Statistics with a Total & Field UT 
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6) Click Statistics > Open Statistics View to open the statistics frame, which appears as shown in 

the figure below: 

 

Figure 52: Statistics with a Total and a Field UT 

In the above example, we have Device# set as Total UT, and Timestamp set as Field UT with 

Frame Count as Statistic Type. This displays the total number of frames with unique timestamp 
value for each device. Since the timestamp is selected as Field UT, additional row displaying the total 
frame count for the timestamp is also displayed. 
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6.1.4 Ranges, Wildcards And Enumerated Value Sets  

Depending on the field type additional criteria may be specified to include only frames with the 
matching: 

 Ranges for numeric fields 

 Wildcards for string fields 

 Sets of values for enumerated fields 

Ranges 

Depending on the field type a range list can be specified for numeric fields as space separated numbers 
or segments of numbers. For example, the range list 1 12-15 4-6 will include fields with the following 
integer values: 1, 4, 5, 6, 12, 13, 14, and 15. Frames with all other values will be excluded from 
statistics see the below figure 

Ranges are valid only for numeric fields. 

 

Figure 53: Range List for Numeric Fields 

Wildcards 

Valid string field values can be specified using wildcard characters „*‟ (asterisk) and „?‟. (question 
mark) 

„*‟ means any zero or more characters 

„?‟ means any single character 

„301*‟, for example, means any string starting with „301‟ 

„301*5*‟ means any string starting with „301‟ and containing „5‟ 

„*3?4?5*‟ means string containing „3‟ followed by any single character followed by „4‟ followed by any 
single character followed by „5‟. 

Wildcards are valid only for string fields. 

 

Figure 54: Wildcards for String fields 
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Value Sets 

Enumerated fields can have a fixed set of values assigned a string name. Some of these string names 

can be selected to narrow down the statistics. See the figure below. 

 

Figure 55: Specifying Value Sets 

 

6.1.5 Modifying and/or removing configured statistics 

 

Figure 56: Modify/Remove some or all statistics 

In the process of the statistics definition one can go to the Selected Statistics Information list 

control and select a line by clicking on it. This will cause automatic repositioning of the tree view and 
statistics information for the selected field to be displayed in the UT, ST and Range/Wildcard/Value 
Set dialogue controls. User can then modify the information and click Add/Mod button to make the 
changes effective as shown in the figure of the Selected Statistics Information list. 

Click Remove Sel button to remove selected lines from the criteria.  

Click Remove All to disable statistics. 

 

6.2 Opening and Closing Statistics View 

Statistics view can be opened and closed any time during offline analysis. Opening a trace view can be 
a lengthy process for large traces when statistics is enabled. 

Statistics view for on-line tracing must be opened before real time analysis is started. 

To open Statistics View select Statistics > Open Statistics view menu item as shown in the figure 
below. 

 

Figure 57: Opening and Closing Statistics View 

To close the Statistics view, select Statistics > Close statistics view menu item. 
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6.3 Loading Statistics 

Select Statistics > Load Statistics (to load the saved statistics criteria as shown in figure below). 

One can load the statistics from a previously saved Statistics Definition File (*.ini). 

 

Figure 58: Loading Statistics 

 

6.4 Load and Edit Statistics 

Select Statistics > Load and edit statistics (to load the saved statistics and to modify the statistics 
information). 

 

6.5 Save Statistics 

Select Statistics > Save Statistics to save the statistics. Save Statistics saves the file with 
configuration details. Enter the desired file name and click Save, the statistics file is saved with 
extension name „.ini‟ (Statistics Definition Files). 

Enter the desired file name and click „Save‟, the statistics file is saved with extension name „.Ini‟ 
(Statistics Definition Files). 

 

Figure 59: Save Statistics as Filename 
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6.6 Export Statistics 

Select Statistics > Export Statistics to export the statistics view into a file with extension ‟sef‟  
(Statistics Export Files) for subsequent import into a database or spreadsheet. 

 

Figure 60: Export Statistics as Filename 
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Section 7.0 Call Detail Records 

The objective of call detail record is to isolate call specific information for each individual call from the 

captured data and display the information in an organized fashion. The call-detail records are displayed 

as shown in the figure below. 

 

Figure 61: Call Detail Records View  

 

7.1 Build Call Detail Record 

Select Call Detail Record > Build Call Detail Record menu item as shown in the figure below. Build 
Call Detail Record is checked for the activation of call trace application. This should be done before 
starting the real-time capture or before opening an hdl file in offline mode. 

 

Figure 62: Build Call Detail Record 
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7.2 Select Call Detail Columns to Display 

Select Call Detail Record > Select Call Detail Columns to Display menu item as shown in the 

figure below. This contains a list of possible Columns. Here we can select the interested columns using 

ctrl key and click OK. 

 Note: 
The Columns can also be selected after opening the Call Data Record view by right-clicking on pane and choosing 
„Select Columns‟ option. 

 

 

Figure 63: Select Call Trace Columns to Display  

Call ID details, the calling status whether the call is active or completed, calling number, called 

number, call start date & time, call duration, release cause, device number, and so on, are shown in 
the call trace view. 

7.3 Active Calls Only 

Select Call Detail Record > Active Calls Only menu item to view all the active calls. 
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7.4 Open Call Detail Record 

Select Call Detail Record > Open Call Detail Record menu item. Call Detail Record View can be 

opened and closed in off-line trace viewing any time. 

To open Call Detail Record View 

 Select Call Detail Record > Open Call Detail Records menu item or  

 Click View > Define Views menu item.  

 

Figure 64: Open Call Detailed Record 

 

 Note: 
 Build Call Detail Record menu item should be checked before opening Call Detail Records view. 
 If the Call Trace view is selected from View>Define Views to Display menu item without checking Build Call 

Detail Record, a warning message is displayed as shown in the figure below. 
 Call Detail Record View for on-line tracing must be opened before on-line tracing is started. 

 

 

Figure 65: Warning Message 
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7.5 Call Detail View 

The following call trace details are available in the call trace view. 

 Call ID: This column shows the number of calls with ID given to each call. 

 Call Status: This shows the status of the call as either active or completed. 

 Calling Number: This shows the caller-related messages. 

 Called Number: This shows the destination number. 

 Call Start Date and Time: This column displays the date (Y/M/D) and the time at which the call 

was captured. 

 Call Duration: This column shows total duration of the completed call. 

 Release Complete Cause: This column shows information, if a call is normally terminated or 

abnormally terminated along with specific cause. 

 DevNo: This column shows the device number, on which the call was captured. 

 CRV: This column displays an arbitrary value that is allocated for the duration of the specific 
session, which identifies the call between the device maintaining the call and the ISDN switch. 

 VPI: The field in the ATM (Asynchronous Transfer Mode) cell header that identifies to which VP 

(Virtual Path) the cell belongs. 

 VCI: The identifier in the ATM (Asynchronous Transfer Mode) cell header that identifies to which 
virtual channel the cell belongs.  

 Type of Call: This column shows information about point-to-point Vs point-to-multipoint call. 

 
 

7.5.1 Active and Completed Calls 

Call ID refers to the identification of each call. There are icons visible to the left of these Call ID 
numbers 

Active Calls:  

Active calls ( ) are marked in green and the call status is specified as Active. An arrow is seen above 

the letter A, which indicates the direction of the call. 

Completed Calls: 

Completed calls ( ) are marked in grey and the call status is specified as completed. An arrow is 

seen above the symbol (-), which indicates the direction of the call. 

 
 

7.5.2 Call Duration 

Call duration is calculated for completed calls. It is the total time for the call from start till the end of 
call. The value is represented in hh.mm.ss.nnnnnn format. 

 

Figure 66: Active, Completes Calls, & Call Duration  
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7.5.3 Find CDR 

This feature allows you to search for a particular call from the captured traces. Right-click on the Call 
Detail View and select Find CDR option to open the screen as shown below: 

 

Figure 67: Find CDR 

Select the parameters from the Column Name and enter the criteria in the Value Wildcard text box. 
The parameters satisfying the conditions may be included or excluded from the result using the 
Include or Exclude options. All the selected criteria logically use OR or AND operations. A frame is 
filtered if at least one criterion matches (OR logic), or each criteria matches (AND logic). 

Wildcards 

All values in Call Detail View are considered as string. To search for a specific call, valid string field 
values can be specified using wildcard characters „*‟ (asterisk) and „?‟. (question mark) 

„*‟ means any zero or more characters 

„?‟ means any single character 

„301*‟, for example, means any string starting with „301‟ 

„301*5*‟ means any string starting with „301‟ and containing „5‟ 

„*3?4?5*‟ means string containing „3‟ followed by any single character followed by „4‟ followed by any 
single character followed by „5‟. 

Wildcards are valid only for string fields. 
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For example, to search for calls with call duration more than 40 seconds, enter the value for Call 
Duration parameter in the wildcard textbox as „00:00:4????????‟.  

Click Add, and then click OK to exit the window.  

This presents the call detail view with Next & Prev navigation button to navigate through records and 
find the calls matching the criteria as shown below. 

 

Figure 68: Specify CDR criteria  

 

7.6 Display Selected Call Summary 

Select the desired call in the call trace view pane and select Call Detail Record > Display Selected 
Call Summary menu item to view the summary details of the specific call. 

Also double click on the specific call in the call Detail Record view pane to view the summary of the 
selected call. 

 

7.7 Display Entire Summary 

Select Call Detail Record > Display Entire Summary menu item to view the entire summary of the 
calls. 

 

7.8 Closing Call Detail Record 

Call Detail Record can be closed form the Call Detail Record>Open & Close Call Detailed Record 
menu item as shown in the figure below or by choosing Close Call Trace View option by right-clicking 
on call detail view. 

 

Figure 69: Close Call Detailed Record 
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7.9 Export Trace File 

Select Call Detail Records > Export menu item or right-click on the call detail view and choose 

Export Call Trace Records option to open the window as shown in the figure below to export the call 
details into a file. It exports the trace file details with extension name “cte” for subsequent import into 
a database or spreadsheet. 

 

Figure  70: Export Trace File  
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Section 8.0 Protocol Analyzer Configuration 

8.1 Analyzer GUI Options and Protocol Configurations 

This window provides a consolidated interface for all the important GUI and Protocol settings required 
in the analyzer. This includes various options such as protocol selection, startup options, 
stream/interface selection, filter/search criteria and so on. 

Select Configure > Protocol and GUI from the main menu, to open the screen as shown in the 
figure below. 

 

Figure 71: Protocol and GUI option 

Additionally, the user can save the configuration settings done in any of these options to a file or just 
revert back to the default values by using the following menu options: 
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Menu Options 

Save: Select Save from the menu to save the configuration settings done in any of the options to a file 

with an extension *.ACF as shown in the figure below. 

 

Figure 72: Save Configuration Options to File 

Load: Select Load to load the previously saved *. ACF file from the location where this file was saved 
as shown in the figure below. 

 

Figure 73: Load Configuration Options 

Default: Click Default from the main menu to revert back to the default settings. 

 

8.1.1 Selecting summary columns to display 

For detail information on this refer to section Summary Column Selection. 
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8.1.2 Menu Checked Options 

This lists the following two options 

 Select View Latest Frame > Packet check box to display the latest frame in the summary view. 

 Select Enable Periodic Trace Saving check box to save the settings of Periodic File Saving 
Specification. 

 

Figure 74: Menu Checked Option 

 

8.1.3 Protocol Standard Selection 

This options is used to select the protocol decode standard. For more information on this refer to 
section Protocol Standard Selection. 

 

Figure 75: Protocol Standard Selection 
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8.1.4 Network/User side Selection 

Select User /Network Side selection to open the window as shown in the figure below. For more 
information on this refer to section User/Network Side Specification. 

 

Figure 76: Network/User side Selection 

 

8.1.5 Time Format 

Four time display formats are supported for both Real-time and Offline analysis. These time formats 
can be changed during both off-line and real-time analysis by selecting the required time format as 
shown in the figure below. For more information on Time Format refer to section Time Displays. 

 

Figure 77: Time Format 

 

8.1.6 View Filter 

This option is used to filter frames displayed in the Summary View. For more information on View 
Filter refer to section Filtering Criteria. 

 

8.1.7 View Search 

This option is used to search the Summary View by decoded Summary column values.  For more 

information on View Search refer to section Setting Search Criteria.  
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8.1.8 TCP Connection Options 

Protocol Analysis probes can run on multiple computers. They are designed to send protocol summary 
information and binary frame data via TCP-IP connection to a Database Loader to load data into a 

database. To set the TCP-IP parameters, select TCP Connection Options from the Database menu 

or click on  button from Configure > Protocol and GUI Options to open the 
window as shown in the figure below. 

 

Figure 78: TCP Connection Options 

In order to test the TCP/IP connection, the probe IP address and the IP Port name must be entered  

Prerequisites for remote protocol analysis probes are following: 

 Database installation and configuration 

 Creating and configuring protocol table  

 Database Loader installation and configuration 

Probes can be configured to filter only subset of frames according to some criteria. For example, to 

load the database with complete information, all the three data types for exporting (loading into 
database), i.e., frame octets, summary fields and status information must be checked or the send 

call details records option must be checked. For detail information on this, refer to GL‟s Net 
Surveyor™. 

 

8.1.9 Periodic trace saving options 

For detail information on periodic trace saving options refer to section Periodic Trace Saving Options.  

http://www.gl.com/netsurveyor.html
http://www.gl.com/netsurveyor.html
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8.1.10 Startup Options 

Startup option is used to enable the startup tasks such as Enable periodic trace saving, Activate Filter, 
Build Call detail records, Connect to a remote database via TCP/IP and Start real-time tracing. 

Click on from Configure > Protocol and GUI Options to open the screen as shown 

below. 

 

Figure 79: Startup Options 

Enable periodic trace saving 

Enables periodic trace saving immediately when analyzer is opened. For more information on this refer 

to section Periodic Trace Saving Options. 

Activate Filter 

Activates filter when analyzer is opened. For more information on this, refer to the section Activate 
Filter. 

Build Call Detail Records 

Activates Call Detail View when analyzer is opened. For more information, refer to Build Call Detail 
Record. 

 

 Note: 
This feature is not applicable to HDLC, MLPPP, and SaHDLC analyzers. 

 

Connect to a remote database via TCP/IP 

 

 Note: 
This feature is applicable to real-time analyzer only. 
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Connects to remote database loader when analyzer is opened. For more information on this refer to 
Net Surveyor™  

Start real-time tracing 

Select the Start real-time tracing check box and click Execute to start the real-time capturing. A 
warning message for overwriting the temporary trace file gets displayed.  If you want to overwrite click 
Yes, else, click No and save it in a new file in the desired location. This new file replaces the default 

specified in the capturing options dialog. For more details refer to section Start Real-time.  

 
 

8.1.11 Data Link Groups (DLG) 

The data link groups help in defining the direction of the calls in a given network. It forms logical 
groups comprised of unidirectional (either „Forward‟ or „Backward‟) data links. This option is essential to 
configuring call detail records (CDR) where redundant signaling links can be used on different T1/E1 
ports and time slots.  

The direction is an essential part of the DLG specification because for many protocols like SS7, GSM 
etc. the CDR fields that are used to separate calls must be swapped depending on the direction.  

All unidirectional data links are grouped under a single name. The name given to DLG is just a case 

sensitive string used to combine multiple data links in a single DLG. 

To invoke a data link group option select Configure > Protocol and GUI from the main menu, and 

click  to open the screen as shown in the figure below. 

 

Figure 80: Data Link Groups 

Data Link Group Specification: 

One or more unidirectional links defined by card, timeslots and sub-channel selection. 

http://www.gl.com/netsurveyor.html
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Select cards, timeslots and sub-channels either directly by mouse or keyboard using extended window 
list box selection that includes the “shift” and “ctrl” keyboard keys for multiple extended selection or 
use “Odd Cards”, “Even Cards”, “All Cards”, “None” push buttons to select or deselect cards.  

Specify the same “Data Link Group Name” sting to combine multiple links in a DLG and also check 

“Forward Link Direction” for forward direction and uncheck for backward direction. The same DLG 
always has the same data link group name string. 

After the specification has been made, click Add to add the selection to the list of DLGs that are 
displayed in the lower part of the pane. 

Data Link Group Display pane 

Displays the current DLG selection 

 Some or all of the unidirectional links can be deleted from the current selection.  

 “Delete Sel” button deletes the selected links from the current selection. 

 “Delete All” button deletes all links from the current selection. 

 “Default” button sets the default selection. 

When the dialog is closed, the current DLG selection is automatically activated. 

The configuration in the above figure has two DLGs: “west” and “east”. The “west” logical link (DLG) 

consists of four unidirectional links on cards (ports) 1, 3 in the forward direction and 2, 6 in the 
backward direction. The “east” logical link consists of two unidirectional data links: a forward link on 
card 5 and 8 and a backward link on card 6 and 7. The data link grouping is essentially a definition how 
to combine unidirectional data links in bidirectional logical links (DLGs) distinguished by their DLG 
Name. 

 
 

8.1.12 View Font Size 

This option allows the user to choose the relevant font size to view the Summary, Detail, Hex, 
Statistics, and Call Detail Records views. Select the option buttons with various font sizes such as Extra 

Large, Large, Normal, Small and Very small. 

 

Figure 81: View Font Size 
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8.1.13 INI Decode Options 

GSM analyzer does not support customizable parameters in GsmProt.INI file. 

 

8.2 Capture Options 

 Note: 
This feature is applicable to real-time analyzer only. 

 

This provides various options such as trace file options, card and timeslot selections, real-time filter 
options, etc. For detail information on this, refer to Capture Menu Features. 
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Section 9.0 Status Indicators 

The analyzer has status indicators at the bottom of the window as shown in figure below: 

 

Figure 82: Analyzer Status Indicators 

9.1 Status and Progress Indicator 

This is the first (leftmost) indicator that displays the following information:  

 Bandwidth utilization (payload bytes (not counting flags) / total bytes (Frame bytes plus flags) 
during real-time capturing. 

 Real-time or off-line mode. 

 Real-time capturing status (Running or stopped). 

 Notification when a long process is in progress, for example, trace is exported, statistics are 
recalculated etc. when the user interface is temporary disabled and the hourglass is being 
displayed. 

 Notification that filtering is active. 

 

 Note: 
Status and progress information is obtained for Real-time Analyzer Only. 

9.2 Trace File Name 

The second indicator displays the trace file name. 

 

9.3 Filtered and Total Frame Count 

The third indicator displays filtered and total frame count when the filtering is active and just the total 
frame count when filter is deactivated. 

 

9.4 Error Counters 

The fourth indicator is blank when no errors are encountered. Separated counts are displayed for cyclic 
redundancy check and framing errors. 
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Application II -  Offline GSM Analyzer 

Section 1.0  Installation 

GL‟s offline protocol analyzers are available as optional software. Functionally, they are similar to real-
time protocol analyzers, but can only perform analysis on pre-captured files. 

For installing offline protocol analyzers, perform the steps given below: 

1.1 Installation Procedure 

The installation procedure for offline protocol analyzer is as follows. 

 Dongle Installation 

 Software Installation 

1.2 Dongle License Installation 

Dongle is a hardware lock, which is installed before installing analyzer software. Each dongle has a 
number uniquely associated with it. To install the dongle hardware and corresponding license, follow 
the steps below: 

 Double-click the setup.exe file in the dongle license installer directory to initiate the install-shield 
wizard. Dongle installs the application license 

 Click Finish in the installation wizard to complete the license installation as shown in the figure 

below: 

 

Figure 83: Dongle License Installation 
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1.3 Software Installation (Windows® 2000) 

 Double-click the executable in the GL‟s protocol analyzer installation CD to open the installation 
shield wizard as shown in the figure below: 

 

Figure 84: Welcome Screen  

 Click Next in the above wizard, and click „Yes‟ to accept the license agreement as shown in the 
figure below: 

 

Figure 85: License Agreement  
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 Select the destination folder to install. The default destination folder is set to \Program Files\GL 
Communications Inc.\Protocol Analyzer. 

 

Figure 86: Choose Destination Folder  

 In the Select Program Folder dialog, click Next to add the program icons to the default folder. 
(This sub-menu will be added to the Start menu). To change the name of the folder, type the new 
name, and then click Next. 

 

Figure 87: Select Program Folder  
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 Status of Installation process is displayed as shown in the figure below: 

 

Figure 88: Setup Status 

 Click Finish to complete the installation of the software. 

 

Figure 89: Protocol Analyzer Installation Completed 

Warning: 
If the user invokes offline analyzer software without installing dongle license, the following message is 
displayed. 

 

Figure 90 : License Error Message 
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Section 2.0 Getting Started with Offline Protocol Analyzer 

Click Offline Analysis to open the interface in offline analysis mode. This mode allows you to analyze 

the pre-captured *.hdl files. To open the trace for Offline Analysis, follow the steps given below: 

 Click File > Off-line as shown in the figure below Or 

 Click Off line from a File  from the tool bar 

 

Figure 91: Open a Trace from a File for Off-line Analysis 

The GUI appears as shown below:  

 

Figure 92: Offline Analysis 
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Appendix A: Filter and Search Criteria 

The Filter/Search Criteria can be used both in real-time and offline analysis. It resembles a tree-like 
structure, which displays various layers defined by the protocol standard selection chosen in View 
Menu > Protocol Standard Selection menu. To set a view or search filter, select View >Protocol 
Standard Selection> View Filter or View Search. 

 

Figure 93: Protocol Standard Selection 

 

 Filter Selection for A Interface 

Data Link Layer 

Frame Length(s) 

Select Frame Length(s) option as shown in the figure below to filter all frames having the specified 
length. Enter a specific value or a range in the Frame Length N or Range Min-Max entry field and 
click Activate to apply the settings. 

 

Figure94: Frame Length 
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Error Frames Only 

Select Error Frames Only option to filter all the error frames. Enter the character Y in the Y for 

Errored Frames only entry field to capture erred frames and click Activate to apply the settings. 

 

Figure 95: Error Frames Only 

OK Frames Only 

Select OK Frames Only option to filter all frames that are error free. Enter the character Y in the Y 

for OK frames only entry field to capture error free frames and click Activate to apply the settings. 

 

Figure 96: OK Frames Only 

Frame Number(s) 

Select Frame Number(s) option to filter all frames having the specified frame number. Enter a value 
or a range in the Frame Numbers entry field and click Activate to apply the settings. 

Frame numbers can be any non-negative numbers and is limited only by the number of frames 
captured to the trace file. 
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Figure 97: Frame Number(s) 

Device Number 

Enter a port using the Device Number option as shown in the figure below and click Activate to 
filter/search for the frames captured on the specified port. 

 

Figure 98: Device Number 

MTP2 Layer 

BSN (Backward Sequence Number) and FSN (Forward Sequence Number) 

BSN and FSN, each of length 7-bit, are used to acknowledge the message signal units from the remote 
end of the signaling link. Enter the values in the range of 0-127 in the BSN Value (or FSN value) 
entry field as shown in the figure below to filter the frames with specific BSN values and click Activate 
to apply the settings. 

For example, enter BSN value as 104 as shown in the figure below to filter the frames that have the 
value as 104. 
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Figure 99: BSN Option 

BIB (Backward Indicator Bit) and FIB (Forward Indicator Bit) 

BIB and FIB, each of length 8-bit, are used in the basic error control and acknowledgement functions. 
Enter the values in the range of 0-255 in the BIB Value (or FIB Value) entry field as shown in the 
figure below to filter the frames with specific BIB (or FIB) values and click Activate to apply the 

settings. 

For example, enter BIB value as 1 as shown in the figure below to filter the frames that have the value 
as 1. 

 

Figure 100: BIB Option 

Status Field 

Select Status Field option to filter all frames having the specified Status Field Value such as, SIO 
(service information octet), SIB (system information block), SIP (session initiation protocol) and so on.  
Click Activate to apply the settings. 
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Figure 101: Status Field Option 

MTP3 Layer 

SLC (Signalling Link Code) 

SLC Link code is a 4-bit code that identifies the link set carrying SS7 signaling information. The range 
of SLC is 0-15. 

 

Figure 102: SLC Option 

DPC (Destination Point Code) 

DPC represents a numeric address that uniquely identifies the receiving signalling point. The number of 
octets in a DPC can vary based on ANSI or ITU standards. For example, select DPC and enter the value 
in entry field as shown in the figure below to filter all frames having the specified DPC address. 
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Figure 103: DPC Option 

OPC (Originating point code) 

OPC represents a numeric address that uniquely identifies the sending signalling point. The number 

of octets in a DPC can vary based on ANSI or ITU standards. For example, select OPC and enter the 
value in entry field as shown in the figure below to filter all frames having the specified OPC address. 

 

Figure 104: OPC Option 
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SCCP (Signaling Connection Control Part) Layer 

SCCP uses subsystem numbers (SSN) to allow messages to be addressed to specific applications 

(called subsystems) at each signaling points. Select the specific message type and SSN values as 
shown in the figure below and click Activate to apply the settings.  

 

Figure 105: Message Type 
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GSM Phase2+ Layer 

BSSMAP (Base Station Subsystem Management Application Part) Message Type 

This is used to convey general BSS (Base Station System) control information between the MSC 

(Mobile Switching Centre) and the BSS. Select the specific BSSMAP message type as shown in the 

figure below and click Activate to apply the settings.  

 

Figure 106: BSSMAP Message Type 
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MM Layer 

Message Type 

Mobility Mgmt messages required to handle the procedures such as handover, Location Update etc of 

Mobile station with respect to circuit switched core network. 

TMSI 

Temporary mobile subscriber identity is a value used to identify the mobile subscriber across the radio 

interface. TMSI is the real identity of the MS and is not usually transmitted over radio interface. 

For example, select Message Type option to filter all frames having the required message type from 
the Message Type Value pane to filter the frames and click Activate to apply the settings. 

 

Figure 107: Mobility Management Message Type 
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CC Layer 

Message Type 

Call control message is used to actually setup the call between MS and circuit switched core network. 
Theses messages are transparently carried over IuCs interface. 

Select a required message type frame from the Message Type Value pane to filter the frames and 
click Activate to apply the settings. 

Called Party/Called Sub Address 

Called party/Called Sub Address number identifies the called party and is present in CC messages. 

Calling Party/Connected/Redirecting# 

Calling party number identifies the calling party and is present in CC messages. 

 

Figure 108: Call Control Message Type 
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SMS Layer 

CP (Control plane) Message Type 

Control plane messages of SMS protocol are used before SMS data is transmitted. 

Select CP Message Type option to filter all frames having the SMS type CP message. Select a 

required message type frame from the CP Message Type Value pane to filter the frames and click 
Activate to apply the settings. 

 

 

Figure 109: CP Message Type 
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RP-MTI 

Relay plane messages of SMS protocol are exchanged before SMS data transfer and carries TP 

messages over it. 

Select RP-MTI option to filter all frames having RP-MTI value. Select a required message type frame 
from the RP-MTI Value pane to filter the frames and click Activate to apply the settings. 

 

 

Figure 110: RP-MTI 
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TP-MTI 

Transport plane messages of SMS protocol are responsible for actual transfer of SMS data over the 

network. These messages contain the actual user data (SMS data) in encoded (7 bit / 8 bit) format. 

Select TP-MTI option to filter all frames having TP-MTI value. Select a required message type frame 
from the TP-MTI Value pane to filter the frames and click Activate to apply the settings. 

 

 

Figure 111: TP-MTI 
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Group Call Control (GCC) Layer 

The Group Call Control (GCC) protocol is one of the Connection Management (CM) sublayer protocols 

used by the Voice Group Call Service (VGCS) on the radio interface within the 3GPP system. 

GCC Protocol Discriminator 

The protocol discriminator specifies the message being transferred. Select the GCC Protocol 
Discriminator Value to be filtered out and click Activate button to apply the settings. 

 

Figure 112: GCC Protocol Discriminator 
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GCC Message Type 

The message type defines the function of each GCC messages. Select the GCC Message Type Value 

to be filtered out and click Activate button to apply the settings. 

 

Figure 113: GCC Message Type 
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Broadcast Call Control (BCC) Layer 

The Broadcast Call Control (BCC) protocol is one of the Connection Management (CM) sublayer 

protocols used by the Voice Broadcast Service (VBS) on the radio interface within the 3GPP system. 

BCC Protocol Discriminator 

The protocol discriminator specifies the message being transferred. Select the BCC Protocol 
Discriminator Value to be filtered out and click Activate button to apply the settings. 

 

Figure 114: BCC Protocol Discriminator 
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BCC Message Type 

The message type defines the function of each GCC messages. Select the BCC Message Type Value 

to be filtered out and click Activate button to apply the settings. 

 

Figure 115: BCC Message Type 
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Reg Test Messages 

Test Messages are used for checking the integrity of the link. A given pattern of octets is sent in SLTM 

message and if the same pattern is received in the SLTM Ack, the link functions properly. 

Select Reg Test Message option to filter all frames having the specified Reg Test Message value, and 
click Activate to apply the settings. 

 

Figure 116: Reg Test Message 
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Network Mgmt Messages 

Network Mgmt messages are used by the network to manage the network, such as bringing a link or a 

group of link from idle to active state or vice versa, exchanging information about the status of a link, 
blocking/unblocking a link etc. 

Select Net Mgmt Message option to filter all frames having the specified Net Mgmt Message value 
and click Activate to apply the settings. 

 

Figure 117: Net Mgmt Message 

NMPC – Enter the NMPC Value to filter/search the frames with the specified value and click Activate 

button to save the settings. 
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 Filter Selection for Abis interface 

For information on setting filtering criteria on various parameters in Data Link layer, refer to Filter 
Selection for A Interface protocol standard. 

LAPD Layer (Link Access Protocol-D channel) 

C/R Option 

The C/R bit indicates whether the frame contains a command or a response corresponding to the 

user/network. Select C/R value accordingly as shown in the figure below to filter frames. 

 

Figure 118: C/R Option 

SAPI (Service Access Point Identifier) 

The Service Access Point Identifier is a 6-bit field that identifies the point where Layer 2 provides a 

service to Layer 3 in OSI. Enter the values in the range of 0-63 in the SAPI Value entry field as shown 
in the figure below. 

 

Figure 119: SAPI 
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TEI (Terminal Endpoint Identifier) 

The terminal end-point identifier (TEI) is a 7-bit field that identifies either a single terminal or multiple 
terminals. A TEI of all ones indicates a broadcast. Enter the values in the range of 0-127 in the TEI 

Value entry field as shown in the as shown in the figure below, to filter the frames belonging to 
different terminal end points. 

 

Figure 120: TEI 

CTL (Control Information) 

Select CTL option as shown in the figure below, to filter frames with different control information (user 

information, supervisory, and unnumbered) 

 

Figure 121: CTL 
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P/F Value (Poll/Final Bit) 

A „1‟ in this bit indicates a poll when frame is a command, and when the frame is a response, a „1‟ bit 

indicates that the current frame is the last frame in the response. Select Poll/Final option accordingly 
as shown in the figure below, to filter the frames with corresponding p/f value 

 

Figure 122: P/F 

N (S) (Send sequence number) 

N (S) is a 7-bit field (0-63) that indicates the send sequence number. Enter the values in the N(S) 

Value entry field as shown in the figure below to filter the frames with a specific send sequence 
number. 

 

Figure 123: N (S) 
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N (R) (Received Sequence Number) 

N (R) is a 7-bit field (0-63) that indicates the number of the next information-frame expected by the 

node at the remote end. Enter the values in the N(R) Value entry field as shown in the figure below to 
filter the frames with specific receive sequence number. 

 

Figure 124: N(R) 

Func (Functions) 

Select Func option to filter frames with different LAPD functions, as listed in the figure below. Click 
Activate to apply the settings. 

 

Figure 125: FUNC 
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BTSM Layer 

BTSM Message 

Layer 3 messages are required to exchange Radio Resource mgmt messages to activate, maintain and 

release radio channel across Abis interfaces. It is also used to carry other DTAP messages such as MM 
/CC / SMS across the interface. 

Select BTSM Message option to filter frames with different messages, as listed in the figure below. Click 
Activate to apply the settings. 

 

Figure 126: BTSM Message 
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Channel Type 

GSM signaling information is mapped to various GSM frame type such as Basic TDMA frame (8 

channels), Multi Frame and Supper Frame etc. A super frame consists of 51 * 26 TDMA frames which 
will have different logical channels and each channel is used for various purposes starting from carrying 

call signaling information, frame synchronization information, user traffic etc. Channel type indicates 
the type of channel being used for signaling SDCCH / BCH / SCH etc. 

Select Channel Type to filter frames with different types, as listed in the figure below. Click Activate to 
apply the settings. 

 

Figure 127: Channel Type 
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Time Slot (Air) 

Each logical channel of a TDMA frame represents one Time slot and each TDMA frame comprises of 

total eight time slots. 

Enter the values in the Time Slot (Air) Value entry field as shown in the figure below to filter the 
frames with specific timeslot value. 

 

Figure 128: Time Slot (Air) 
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Sub Channel (Air) 

Each logical channel is further divided, and each fraction is known as sub channel. 

Enter the values in the Sub Channel (Air) Value entry field as shown in the figure below to filter the 

frames with specific timeslot value. 

 

Figure 129: Sub Channel (Air) 
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RR Layer 

RR-Message 

Radio Resource mgmt messages required to activate, maintain and release radio channel across Abis 

interfaces. 

Hopping Channel 

Gives information about type RF channel viz. single RF channel and RF Hopping channel 

Absolute RF Channel# 

This is an identifier for the channel 

Hopping Sequence 

A GSM phone served by a cell that is hopping over a set of frequencies, separate traffic channels hop 
over the allocated frequencies according to a hopping sequence number (HSN). The traffic channels 
with the same HSN hop over the same frequencies in the same order but are separated in time by a 
mobile allocation index offset (MAIO). 

Select a RR message to filter the frames of RR types, as listed in the figure below. Click Activate to 
apply the settings. 

 

Figure 130: RR Message 

MM Layer 

For more information on this refer to MM Layer. 

CC Layer 

For more information on this refer to  

CC Layer. 

SMS Layer 

For more information on this refer to SMS Layer. 

Group Call Control (GCC) Layer 

For more information on this refer to GCC Layer. 

Broadcast Call Control (BCC) Layer 

For more information on this refer to BCC Layer. 
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 Filter Selection for Gs-PCS interface 

Filter selection for Gs-PCS interface is similar to A-Interfaces. For more information on Data Link, 
MTP2, MTP3, SCCP, refer to section Filter Selection for A Interface. 

BSSAP+(Base Station System Application Part Plus) Layer 

BSS Application Part plus is used to support signaling between the VLR (Visitor Location Register) and 
SGSN (Serving GPRS Support Node) on the Gs interface. Location information about the user may be 
exchanged between SGSN and MSC across the Gs interface. 

Message Type 

Select a BSSAP message type value to filter the required type of frames, and click Activate to apply 
the settings. 

 

Figure 131: BSSAP Message Type 
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 Filter Selection for Up Interface UMA (Unlicensed Mobile Access Protocol) 

Data Link Layer 

For information on setting filtering criteria on various parameters in Data Link layer, refer to Data Link 

Layer. 

MAC (Medium Access Control) Layer 

VLAN ID- VLAN ID is the identification number of 12 bits that can allow the identification of (2^12 –2) 

VLANs. Enter the VLAN ID value in the entry field to filter the frames accordingly. 

 

Figure 132: VLAN ID 

Ethernet Encoded TPID- TPID has a defined value of 8100 in hex. When a frame has the Ether type 
equal to 8100, this frame carries the tag IEEE 802.1Q / 802.1P as shown in the figure below. Select 

the required TPID value to filter the frames accordingly. 

 

Figure 133: Ethernet Encoded TPID 
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Higher Layer Protocol: Select Higher Layer Protocol option to filter all frames in the specified layer 
such as IP, ARP, etc as shown in the figure below. Click Activate to apply the settings. 

 

Figure 134: Higher Layer Protocol 

IP (Internet Protocol) Layer 

Source IP Address –This is the address of a source node that uniquely identifies the source computer 

while participating in LAN/WAN communication. 

Destination IP Address- This is the address of a destination node that uniquely identifies the source 

computer while participating in LAN/WAN communication. For example, select source IP address as 
shown in the figure below to filter the frames those have source IP address value as 192.168.1.83. 
Similarly, select destination IP address to filter the frames those have source IP address value as 

172.17.1.18. Click Activate to apply the settings. 

 

Figure 135: IP Layer - Source Port 
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TCP (Transport Control Protocol) Layer 

TCP Source Port – This is a 16-bit unassigned port number assigned to the sending application called 

TCP source port. 

TCP Destination Port –This is a 16-bit unassigned port number assigned to the receiving application 
called TCP destination port. Select TCP Source Port option and enter the port value (say 2050) to 
filter the frames through this port of sending application. Similarly, select TCP Destination Port and 

enter the port value to filter the frames through this port of receiving application. Click Activate to 
apply the settings. 

 

Figure 136: TCP Layer - Source Port 

UDP (User Datagram Protocol) Layer 

UDP Source Port - The source port is the virtual 16-bit port number assigned by the local computer 

when it transmits data to a remote machine. This is typically a number above 1023. 

UDP Destination Port - The destination port is also a 16-bit port number, usually a 'well known port 
number' such as 69 for trivial file transfer protocol, or 53 for DNS. When used with a source port, this 

allows a remote machine to recognize a data connection. For example, select UDP Source Port as 
shown in the figure below and enter the port value (say 1023) to filter the frames with specific UDP 
source port number. Similarly, select UDP Destination Port and enter the port value to filter the 
frames with specific destination port number. Click Activate to apply the settings. 

 

Figure 137: UDP Layer - Source Port 
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 Filter Selection for Lb, Ls, Lp-Interfaces 

 

Figure 138: Filter Selection for Lb, Ls, Lp Interface 

Data Link Layer 

For information on setting filtering criteria on various parameters in Data Link layer, refer to Data Link 
Layer 

MTP2 Layer 

For information on setting filtering criteria on various parameters in MTP2 Layer, refer to MTP2 Layer 

MTP3 Layer 

For information on setting filtering criteria on various parameters in MTP3 Layer, refer to MTP3 Layer 

SCCP (Signaling Connection Control Part) Layer 

For information on setting filtering criteria on various parameters in SCCP Layer, refer to SCCP Layer 

BSSAP-LE (BSSMAP-LE/DTAP-LE) - Base Station System Application Part Layer 

BSSAP-LE is an extension to BSSAP (Base Station System Application Part) that contains 
messages and parameters specific in the support of LCS (Location Services). The following subsets of 

BSSAP-LE are defined as BSSMAP-LE (Base Station System Mobile Application Part - LCS 

Extension) and DTAP-LE (Direct Transfer Application Part - LCS Extension). 

Message Type 

Select a BSSAP-LE message type value to filter the required type of frames, and click Activate to 
apply the settings. 

 

Figure 139: BSSAP-LE Message Type 
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SMLCPP 

Serving Mobile Location Center Peer-to-Peer Protocol (SMLCPP) is a transport protocol for the 

communication between the Serving Mobile Location Centers (SMLCs).  

BSSLAP 

The BSS LCS Assistance Protocol (BSSLAP) and the BSSAP LCS Extension (BSSAP-LE) support LCS 

functions (e.g., positioning measurements, assistant measurements) and is independent of lower 
protocol layers. The BSSLAP layer may be absent if its functions are supported in the BSSAP-LE layer. 

Message Type 

Select a BSSLAP message type value to filter the required type of frames, and click Activate to apply 
the settings. 

 

Figure 140: BSSLAP Message Type 
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 Filter Selection for Mobis-Interfaces 

Data Link Layer 

For information on setting filtering criteria on various parameters in Data Link layer, refer to Data Link 

Layer. 

LAPD Layer 

For information on setting filtering criteria on various parameters in LAPD layer, refer to LAPD Layer. 

Mobis Layer 

Mobis supports 2 packet header types - – Compact and Executive. 

This layer allows users to filter the captured file based on the protocol message types and interface 
message types corresponding to the packet headers types – Compact and Executive. 

 

Figure 141: Mobis Message & Interface Types 

RR Layer 

For information on this refer to RR Layer. 

MM Layer 

For more information on this refer to MM Layer. 

CC Layer 

For more information on this refer to CC Layer 

SMS Layer 

For more information on this refer to SMS Layer. 

Group Call Control (GCC) Layer 

For more information on this refer to GCC Layer. 

Broadcast Call Control (BCC) Layer 

For more information on this refer to BCC Layer. 
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